Programmeren met Python in de Livewires-cursus

Inleiding

I.p.v. hoofdstuk 3 uit Turing (programmeren met Java) gaan we programmeren met Python. We gebruiken hiervoor de Engelstalige Livewires Pythoncursus, die te vinden is op http://www.livewires.org.uk/python/.

Van ieder hoofdstuk uit de cursus komt er ook nog een korte Nederlandse samenvatting met de belangrijkste zaken, die je in dat hoofdstuk geleerd hebt, aangevuld met wat extra informatie over programmeren (in Python) en soms met wat extra opgaven.

Let op: De leerstof voor dit hoofdstuk bestaat dus uit de volgende onderdelen:

· Par. 3.1 uit het boek (zowel IB als VB).

· De Livewires-cursus

· De aanvullingen, waarvan dit document de eerste aanzet is.

Behalve de ELO voor de werkwijzer en extra bronnen is er ook een website met extra materiaal voor onze cursus programmeren: http://python.vdweijden.org .

Op dit moment staat daar al de Python-programmeeromgeving, die je kunt downloaden en op je eigen computer thuis kunt installeren, zodat je ook thuis met Python kunt werken. Hiervoor heb je dan ook de livewires-module nodig, die daar ook te downloaden is (zie verderop voor instructie over installeren van Python en livewires-module). Tenslotte is daar de gehele Pythoncursus van livewires te vinden, inclusief een aantal bijlagen, die in de cursus genoemd worden.

De in de cursus en dit document vermelde bijlages kan je ook op bovenstaande site lezen.

Niet alleen maar de handleiding doorlezen maar echt alle code zelf in IDLE uitproberen. Zeker ook alle challenge-opdrachten uitvoeren. Alle resultaten en door jou gemaakte codes moet je in je schrift schrijven! Daarbij heb je vanaf hoofdstuk 2 een diskette nodig om je programma’s op te slaan.
Installatie

1. Ga naar python.vdweijden.org en download de programmeeromgeving. Dit is een .exe-bestand, waarmee je door te dubbelklikken de programmeeromgeving installeert. Na de zichzelf wijzende installatie van het programma moet je via Start -> Programma’s -> Python2.1 het programma kunnen opstarten.

2. Ga naar python.vdweijden.org en download de livewires-module. Dit is een .tar.gz-bestand, die je gewoon met Winzip kunt uitpakken (extract). Dubbelklik vervolgens op setup.py. Als het goed is, wordt er nu een DOS-venster geopend, waarin een aantal regels tekst ontstaan en vervolgens het DOS-venster weer gesloten. Om te kijken of de module goed geïnstalleerd is open je het programma Python2.1 en vult op de eerste regel van het IDLE-venster de volgende tekst in: from livewires import * . Druk vervolgens op Enter. Wanneer je geen foutmelding in je IDLE-venster krijgt, is de livewires-module goed geïnstalleerd en ben je (voorlopig) klaar met je installatie. Zo niet, ga dan door naar punt 3.

3. Als het toevoegen van de livewires-module niet automatisch gelukt is met setup.py, dan moet je handmatig de map livewires (let op: niet de map LiveWires-2.0, maar de map livewires, die in de map LiveWires-2.0 te vinden is) verplaatsen naar de map Python21. Probeer nu weer eens in het IDLE-venster de tekst: from livewires import *. Als het goed is, moet je nu geen foutmelding krijgen.

Hoofdstuk 1

Aanpassingen in tekst

Geen.

Aanvullingen en opmerkingen

Pagina 1: De programmeeromgeving IDLE van Python.
Begin met de programmeeromgeving IDLE van Python te openen via Start->Vakken->Informatica->Python (thuis: Start->Programma’s->Python2.1->IDLE (Python GUI)).

In het nu geopende venster kan je programmacode invoeren achter de ‘prompt’ >>>.

Dit venster is bedoeld om ‘losse’ programma-instructies uit te testen en is goed genoeg voor hoofdstuk 1. Wanneer je hele programma’s gaat schrijven, dan moet je via File->New Window een nieuw venster openen. Dat zullen we gebruiken vanaf hoofdstuk 2. Meer informatie over hoe met Python te werken is te vinden in bijlage R.

Pagina 2: Verschillende typen 

Voer in: >>> 7/3 en kijk wat het resultaat is.

Voer vervolgens in >>> 7.0/3 en kijk wat het resultaat is.

Enig idee, hoe dit mogelijk is?

In iedere programmeertaal heb je verschillende typen gegevens waarmee je kunt werken. In het eerste geval heb je gebruik gemaakt van twee gehele getallen (in programmeertaal: integer). Als je een berekening uitvoert met alleen maar integers (gehele getallen), dan zal het resultaat ook een integer zijn, waarbij alles achter de komma gewoon weggelaten wordt (dus niet afgerond; probeer maar 8/3; dat geeft ook 2 als resultaat). Wanneer je echter minimaal één decimaal getal (in programmeertaal: double of float) in de berekening hebt staan, geeft het resultaat ook een decimaal getal.

Het tweede dat opvalt, is het laatste cijfer achter de komma: dat is een 5 terwijl je een 3 verwacht. Dat is de afrondfout, die bij het berekenen gemaakt wordt. Python werkt standaard maar tot in een bepaald aantal cijfers nauwkeurig. Wil je een grotere nauwkeurigheid, dan moet je dat aan Python doorgeven (hebben wij echter niet nodig).

Een derde type, waarmee Python kan werken is tekst (in programmeertaal: string). Als je aan wil geven, dat iets tekst is, dan moet het wel tussen enkele of dubbele (mag allebei, maar wel consequent) aanhalingstekens staan. Voorbeeld: “Dit is een string” of  ‘en dit is ook een string’.

Een vierde type zijn lijsten (in programmeertaal: list of array). Hierin kan je meerdere gegevens van een bepaald type kwijt. Voorbeeld van een lijst met een aantal gehele getallen: [1, 2, 3, 4].

Tenslotte is er nog een type, dat in programmeertaal boolean genoemd wordt. Deze kan alleen maar de waarde true of false hebben (waar of niet waar). Dit type komen we pas in hoofdstuk 2 tegen.

Pagina 3: variabelen

Wanneer we een gegeven van een bepaald type meerdere keren willen gebruiken, dan geven we deze een naam (in programmeertaal: variabele). Dat doen we in een toekenning (in het Engels assignment) met een =-teken. Voorbeeld: voornaam = “Kees” of aantal = 9 of cijferlijst = [4,5,8,3,7].

Pagina 4: herhaling met for

Eén van de elementen in de basisstructuur van een computerprogramma is de herhaling (zie IB par. 3.1). Deze kan op verschillende manieren uitgevoerd worden. De eerste manier is met de for-opdracht. Deze opdracht wordt gebruikt, wanneer je van te voren precies weet voor welke waarden je de herhaling plaats wil laten vinden. De volgende inspringende statements zullen voor de na de for vermelde waarden uitgevoerd worden.

Voorbeeld: zie cursus.

Voor meer informatie over herhalingslussen zie bijlage L.

Pagina 4: print-opdracht 

Wanneer je iets op het scherm afgedrukt wil hebben, gebruik je de print-opdracht. Je kunt meerdere gegevens van verschillende typen in één printopdracht laten afdrukken door de verschillende gegevens achter de print-opdracht te zetten, van elkaar gescheiden door een komma.

Voorbeeld:

>>> voornaam = “Jan”

>>> leeftijd = 15

>>> print voornaam, “is”, leeftijd, “jaar.”
Resultaat: Jan is 15 jaar.
Pagina 4: foutmelding

Als je programmacode niet klopt, dan krijg je een foutmelding van Python. Daar is vaak geen wijs uit te halen. Niet zo erg. Bekijk je code nog eens goed en zoek zelf de fout. Soms kan je nog uit de laatste regel van de foutmelding afleiden wat de fout ongeveer moet zijn. Meer informatie over foutmeldingen is te vinden in bijlage E.

Algemeen: expressie, operaties, operanden
Voorbeeld: uitkomst = 25 * 45
Het geheel is een toekenning (assignment). Links van het =-teken staat de variabele, waaraan het resultaat van de rechterkant van het =-teken toegekend wordt. Aan de rechterkant staat een expressie met de twee operanden 25 en 45 en de operatie * (voor operanden en operatie zie IB hoofdstuk 2 blz. 31 en 32).

Samenvatting (wat moet je kennen?)
· We werken met vijf typen gegevens: gehele getallen (integer), decimale getallen (float of double), tekst (string), boolean (true of false), lijsten (list of array).

· Met + teken kunnen niet alleen getallen opgeteld worden maar ook strings aan elkaar ‘geplakt’ worden. Let wel op, dat je altijd gegevens van hetzelfde type door een +-teken met elkaar verbindt.

· Berekeningen met alleen gehele getallen geeft een geheel getal als antwoord. Alles achter de komma wordt ‘afgekapt’. Staat er minstens één decimaal getal in de berekening, dan zal de uitkomst ook een decimaal getal zijn.

· Teksten (strings) moeten tussen enkele of dubbele aanhalingstekens.

· Lijsten tussen vierkante haken, bijv. [1,4,5,8].

· Je kunt een gegeven of het resultaat van een expressie toekennen aan een variabele. Dat kan voor ieder type gegeven. Deze variabele kan je dan verder gebruiken alsof deze het gegeven zelf is.

· Een herhalingsconstructie kan je maken met for, bijv. for x in 1,2,3,4,5,6:
De volgende regel(s), die dus herhaald moeten worden, moeten inspringen (doet de IDLE automatisch).

· Met een print-opdracht kan je gegevens rechtstreeks of via een variabele op het scherm afdrukken. Dit mogen meerdere gegevens zijn van verschillende typen, als ze maar van elkaar gescheiden worden door een komma.

· In een toekenning (assignment) staat links van het =-teken de variabele en rechts de expressie, die meestal uit twee operanden en één operatie bestaat.

Samenvatting (wat moet je kunnen?)
· De IDLE van Python opstarten.

· Code invoeren en laten uitvoeren.

· Bovenstaande theorie (wat moet je kennen?) kunnen toepassen in IDLE.

· Twee trucjes:

· met Ctrl-Z kan je de laatste regels ongedaan maken en terug naar een hogere regel (handig om na een foutmelding terug te gaan naar de foute regel)

· wil je een regel nog eens invoeren, zet dan je cursor in die regel en druk op Enter.

Lees op de python.vdweijden.org site bijlage R (Running Python) door.

Opdrachten
De uitwerkingen moeten in je schrift opgeschreven worden.

1. Ken je voornaam en je achternaam aan twee variabelen toe, evenals je leeftijd en je geboortejaar en zorg dat je met een print-opdracht en deze vier variabelen de volgende zin (met je eigen gegevens) op het scherm krijgt:
Mieke Jansen is geboren in 1987 en is nu 16 jaar.

2. Zorg dat met een for-herhaling de tafel van 4 op het scherm verschijnt. Dus:
1 keer 4 is 4
2 keer 4 is 8
3 keer 4 is 12
enz. t/m 10 keer 4 is 40
3. Teken een blauwe rechte lijn op het scherm van (150,200) naar (250,100)

Hoofdstuk 2

Aanpassingen in de tekst

Pagina 3: Halverwege de pagina bij de Challenge-opdrachten wordt het tijd om over te schakelen van een Python-sessie naar het echt programmeren in een volledig programma. Via File->New Window wordt er een nieuw venster geopend. Hierin kan je een volledig programma maken. Dit programma moet je opslaan voordat je het kan uitvoeren (run). Sla het dan op op een diskette. Opslaan via File->Save en vervolgens de goede map kiezen om het bestand op te slaan (bijv. de diskette); voeg als extensie altijd .py toe. Natuurlijk kan je zo ook via File->Open... een Python-programma openen.

Het uitvoeren van een Python-programma gaat dan via Edit->Run Script (of via Ctrl-F5). Het resultaat is dan in het eerste scherm weer te zien (of het grafisch scherm, wanneer daar gebruik van gemaakt wordt).

Je kan het eerste scherm gebruiken om afzonderlijke opdrachten uit te proberen (een sessie) en het tweede om gehele programma’s te schrijven.

Verdere informatie over het gebruik van de IDLE-werkomgeving van Python zie bijlage R.

Aanvullingen en opmerkingen

Pagina 1 en 2: Het opzetten van een programma

In dit hoofdstuk ga je een programma maken, waarbij de gebruiker tien willekeurige maalsommetjes van de tafels 1 t/m 10 moet maken. Het programma geeft aan of het antwoord goed of fout is en aan het eind hoeveel opgaven de gebruiker in totaal goed en hoeveel hij/zij fout had.

De vier fasen voor het schrijven van een computerprogramma worden doorlopen (zie IB § 3.1). Allereerst wordt het probleem beschreven (welk resultaat moet het programma opleveren? programma van eisen), vervolgens wordt er nagedacht over het oplossen van het probleem (analyse; welke stappen moeten er allemaal in het programma voorkomen), daarna wordt er begonnen met programmeren (om tussendoor  en aan het eind te testen en te kijken of het programma aan de gestelde eisen voldoet en/of verbeterd kan worden).

Pagina 2: de Livewires-module

Vergeet in deze cursus nooit in een programma te beginnen met de regel:

from livewires import *
Daarmee haal je de modules van de LiveWires-cursus binnen je programmeeromgeving, waarin een aantal functies staan, die je dan kunt gebruiken (bijv. random_between(10,15). Er zijn voor Python veel modules gemaakt met extra functies, die je kunt gebruiken, maar dan moet je ze wel eerst in je programmeeromgeving importeren (binnenhalen). Ook de makers van deze cursus hebben speciaal voor deze cursus modules gemaakt, die in de cursus gebruikt moeten worden. Deze moeten dan wel via de import-opdracht geïmporteerd worden.

Voor meer informatie over modules zie bijlage M.

Pagina 4: if ofwel het keuze-element in de basisstructuur (zie IB par 3.1)
Als er een keuze gemaakt moet worden (“als dit waar is dan moet dit gebeuren, zo niet dan moet dat gebeuren”) wordt in vele programmeertalen if ….. else gebruikt. Ook zo in Python. Na de if komt datgene te staan dat waar (true) of niet waar (false) is. Daar staat dan een zgn. logische expressie, waarbij de volgende relationele operatoren gebruikt kunnen worden:

· > (groter dan)

· >= (groter dan of gelijk aan)

· < (kleiner dan)

· <= (kleiner dan of gelijk aan)

· == (gelijk aan)

· <> (niet gelijk aan)

Deze logische expressie heeft dan de boolean-waarde true of false. Als deze de waarde true heeft, dan worden de volgende inspringende opdrachten uitgevoerd, als deze de waarde false heeft, dan worden de inspringende opdrachten na else: uitgevoerd. Let op: een else: is niet verplicht. Het kan heel goed zijn dat als de logische expressie false is, dat er dan niets hoeft te gebeuren.

Voor voorbeeld: zie cursus.

Algemeen zeer belangrijk: De instructies, die uitgevoerd moeten worden na een if, for of while of na een functiedeclaratie (komt later nog) moeten altijd INSPRINGEN. Zo weet Python, dat dat de instructies zijn die bij die if, for of while of functiedeclaratie horen!!!
Voor verdere informatie over logische expressies zie bijlage C.

Pagina 5: Toekenning

Het statement odd = odd + 2 ziet er wiskundig nogal vreemd uit. Maar bedenk, dat odd niets anders is dan een naam voor een geheugenruimte waar een waarde in zit. Het enige, dat er in bovenstaande gemeld wordt is dus “stop in geheugenvak met de naam odd datgene dat er al in zit maar dan met 2 opgeteld” ofwel “nieuwe odd wordt de oude odd plus 2”.

Samenvatting (wat moet je kennen?)
· Er zijn vele modules voor Python beschikbaar, die functies bevatten, die je kan gebruiken. Maar dan moet je die module(s) wel eerst in je programma importeren.

· Voor het keuze-element wordt de if …. else constructie gebruikt. Na if volgt een logische expressie, die de boolean-waarden true of false kan hebben. Indien true, dan worden de statements na if uitgevoerd, indien false dan worden de statements na else: uitgevoerd. Deze laatste hoeft niet aanwezig te zijn.

· Na een if-, else-, while-, for- of functie-statement (vergeet nooit de : aan het eind van de regel) moeten de uit te voeren statements altijd inspringen.

· x = x * 3 betekent: de nieuwe variabele x krijgt de waarde van de oude variabele x maal 3.

Samenvatting (wat moet je kunnen?)
· Modules importeren met de import-opdracht.

· Gebruik kunnen maken van keuze-element:
if logische expressie:
    statements
else:
    statements
· Gebruik kunnen maken van herhalings-element:
for x in 1,2,enz.:
    statements (met x)
Opdrachten
De uitwerkingen moeten in je schrift opgeschreven worden
1. Schrijf heel het in dit hoofdstuk ontwikkelde (en werkende) tafelprogramma in je schrift.

2. Voer minstens twee van de vier suggesties ter verbetering van het programma (zie blz. 5) uit en schrijf deze ook in je schrift.

Hoofdstuk 3

Aanpassingen in tekst

Pagina 3:
· Eerste stukje programma: daar moet een regel tussen. Wordt dan:
from livewires import *
begin_graphics()
circle(300,200,100)
· Ook in tweede stukje programma moet na de eerste regel hetzelfde toegevoegd worden:
from ...enz.
begin_graphics()
for r in ... enz.
Pagina 4:
· Eerste stukje programma moet worden:
circle(300, 195, 25, endpoints = ((280,180), (320,180)))
Aanvullingen en opmerkingen

Algemeen:
In dit hoofdstuk wordt er getekend. In de livewires-module zijn hiervoor bepaalde functies opgenomen om het tekenen in een programma makkelijker te maken. Om aan te geven, dat je gaat tekenen moet je beginnen met de functie begin_graphics(). Dan wordt er een speciaal tekenvenster geopend. Om aan te geven dat je klaar bent met tekenen gebruik je de functie end_graphics(), maar ... die sluit dan ook direct het tekenvenster. Je moet die laatste functie niet te snel gebruiken, aangezien je dan vaak niet de kans krijgt om de tekening te bekijken.

Bij het tekenen stellen de getallen de pixels van je tekenvenster voor. Linksonder in de hoek ligt het punt (0,0), waarbij het eerste getal de horizontale positie (x-richting) en het tweede getal de verticale positie (y-richting) aanduidt.

Pagina 1 t/m 4: tekenfuncties
De in dit hoofdstuk gebruikte tekenfuncties zijn:

	move(x,y)
	beweeg zonder te tekenen naar punt (x,y)

	draw(x,y)
	teken vanaf waar je nu staat verder naar punt (x,y)

	set_colour(Colour.red)
	vanaf nu wordt er in de aangegeven kleur getekend (hier dus rood)

	circle(x,y,r)
	teken een cirkel met middelpunt (x,y) en straal r

	circle(x,y,r,endpoints=((x1,y1),(x2,y2)))
	teken een deel van een cirkel met middelpunt (x,y), straal r en beginpunt (x1,y1) en eindpunt (x2​,y2)


Voor meer informatie over tekenen in Python zie bijlage G.

Pagina 5: het definiëren van functies

Wanneer je binnen een programma vaker gebruik wil maken van een stukje uit dat programma, dan kan je daar een functie van maken en die aanroepen op de plaats(en) in je programma waar je dat stukje programma nodig hebt. De eerste regel van zo’n functie begint altijd met def, gevolgd door de naam, die je aan de functie wil geven, met openings- en sluitingshaakje achter die naam en afgesloten door :
Het stukje programma, dat opgeroepen moet worden door deze functie komt dan op de volgende regels. Let op: ook nu moeten deze regels inspringen, zodat Python weet, welke regels deel uit maken van de functie. Aangeven, dat een statement niet meer bij de functie hoort kan eenvoudig door het inspringen bij deze statement weer te beëindigen. Voorbeeld:

def waarheid():


print ‘Onze infodoc is geweldig!’


print ‘En ik lieg nooit.’

waarheid()
geeft als resultaat:

Onze infodoc is geweldig!

En ik lieg nooit.
Een functie kan ook één of meerdere argumenten hebben, die tussen de haakjes komen te staan. Zo kan je een waarde aan de functie doorgeven, waarmee deze kan werken. Voorbeeld:

def idol(favoriet, knurft):


print ‘Mijn idol is’, favoriet


print knurft, ‘vind ik helemaal niets.’

idol(‘Jamai’,’Jim’)
geeft als resultaat:

Mijn idol is Jamai

Jim vind ik helemaal niets.
Andere voorbeelden kan je in het hoofdstuk zelf vinden.

Voor meer informatie over functies zie bijlage F.

Samenvatting (Wat moet je kennen?)
· Tekenen begint met begin_graphics() en eindigt met end_graphics()
· De plaats in het tekenvenster wordt met resp. de x- en y-coördinaten van een pixel aangegeven (x,y), waarbij linksonder pixel (0,0) is.

· Zie boven de diverse tekenfuncties.

· Een stukje programma kan je in een functie definiëren, al of niet met argumenten. Deze functie kan je vervolgens overal in het programma aanroepen.

Samenvatting (Wat moet je kunnen?)
· Een tekenvenster openen en tekeningen maken met de functies move, draw, circle en set_colour.

· Zelf functies definiëren en in een programma oproepen zowel zonder als met argumenten.

Opdrachten

De uitwerkingen moeten in je schrift opgeschreven worden.

1. Ontwerp het figuur van pagina 8, waarbij het gezicht met de functie draw_face(x,y) van de vorige pagina’s getekend moet worden.

2. Maak vervolgens een functie teken_figuur(x,y) van je figuur uit opdracht 1, zodat je meerdere figuren in het tekenvenster kan zetten en probeer dit uit.

3. Maak een functie bereken(x,y), die achtereenvolgens x en y optelt, van elkaar aftrekt, vermenigvuldigt en deelt, zodat het resultaat van bijv. bereken(18, 6) is:
18 + 6 = 24
18 – 6 = 12
18 * 6 = 108
18 : 6 = 3
Hoofdstuk 4

Aanpassingen in de tekst

Geen.

Aanvullingen en opmerkingen

Algemeen: gebruik IDLE

Zoals al eerder opgemerkt, je hebt twee vensters, die je in IDLE kunt gebruiken. Het Python Shell venster (waarmee IDLE opent) om de werking van korte statements uit te testen en het programmavenster (te openen met File->New Window). Bouw het programma van dit hoofdstuk op in het programmavenster en probeer de losse statements uit in het Python Shell venster.

Om het programma tussentijds uit te testen moet je het eerst opslaan (geef het de eerste keer een naam met extensie .py, bijv. raad_getal.py ) en dan runnen via Edit->Run script (of  Ctrl-F5).

Soms moet je na het uitproberen van een programma twee keer op Enter drukken in het Python  Shell venster voordat je weer de prompt >>> te zien krijgt, waarachter je de volgende statements kunt opschrijven.

Begin in beide vensters met de regel from livewires import *
Pagina 2: while, true, false

In de vorige hoofdstukken hebben we al de herhalingslus met for gebruikt. Deze is geschikt als je van te voren precies weet hoeveel keer de lus herhaald moet worden, maar soms is dat van te voren niet duidelijk. Dan moet de lus herhaald worden, totdat aan een bepaalde voorwaarde voldaan wordt. Bijv. while x  < 100:
Na de while volgt dan een logische expressie, die waar (true) of niet waar (false) is, afgesloten door : . Zolang deze true is, zal de herhalingslus weer doorlopen worden. Als deze false is, wordt de herhalingslus niet meer doorlopen en gaat het programma gewoon verder.

Pagina 3: while 1: ,break

Om aan te geven of iets waar of niet waar is (true of false) wordt gebruik gemaakt van het getal 0 voor false en 1 (of ieder ander getal dat niet 0 is) voor true.

Je kunt daarmee een herhalingslus maken, die eeuwig door gaat, omdat na de waarde na de while steeds true is. Dat doe je met: while 1:
Maar dan moet je wel op een andere manier de herhalingslus onderbreken, als er aan een bepaalde voorwaarde voldaan wordt m.b.v. een if-statement gevolgd door een break. Een break betekent: stop onmiddellijk met de herhalingslus, waar je nu in zit en ga verder met de rest van het programma.

Voorbeeld:

while x < 100:

kan je ook schrijven als:

while 1:

   if x >= 100:

      break


Pagina 3: if ....: ......elif:......else:.......
Wanneer je bij een keuze maar twee mogelijkheden hebt kan je gebruik maken van de constructie if ....: else: . Maar soms zijn er meer dan twee mogelijkheden. Bijv. in het raadspel van dit hoofdstuk: je kunt te hoog, te laag of goed geraden hebben. Dan is er een extra commando elif: (afkorting voor else if), die je kunt gebruiken. Voorbeeld:

if gok > keuze:

   ............

   ............

elif gok < keuze:

   ............

   ...........

else:

   ...........

   ...........
Pagina 3: read_yesorno()
Bij de functie read_yesorno() wordt de gebruiker gevraagd om een antwoord (yes of no). Als je de waarde vervolgens zichtbaar wil maken, dan blijkt deze 1 te zijn, wanneer je yes en 0 wanneer je no geantwoord hebt. Dat komt omdat het antwoord yes gezien wordt als de boolean-waarde true (dus 1 in Python) en no als false (dus 0 in Python).

Samenvatting (Wat moet je kennen?)
· Bij herhalingslussen zijn er twee constructies die je kunt gebruiken:

· for  als je van te voren weet hoe vaak de herhalingslus doorlopen moet worden.

· while als je niet van te voren weet hoe vaak de herhalingslus doorlopen moet worden maar wel onder welke voorwaarde.

· De while constructie kan ook geschreven worden als:
while 1:
   if .....:
       break
· Bij de keuzeconstructie met meer dan twee keuzes heb je naast if ....: else: ook de mogelijkheid elif: Deze kan indien nodig meerdere keren gebruikt worden.

Samenvatting (Wat moet je kunnen?)
· Omgaan met zowel het Python Shell venster voor het uitproberen van losse statements of korte stukjes programma als het programmavenster voor gehele programma’s.

· Gebruik maken van de herhalingslus constructies en de keuzeconstructie met meer dan twee keuzes.

· Gebruik maken van de read_yesorno() functie.

Opdrachten

De uitwerkingen moeten in je schrift opgeschreven worden.

1. Maak het raad-programma van dit hoofdstuk

2. Voer minstens twee van de verbeteringen, die als suggestie aan het eind van het hoofdstuk staan (pagina 4), uit.

3. Maak een programma, waarbij de gebruiker de titel van een boek moet opgeven, waarna het programma de naam van de schrijver geeft. Voer minstens drie titels en schrijvers in in het programma en zorg ervoor, dat als de gebruiker een titel opgeeft, dat niet in het programma voorkomt, het programma daar een melding van geeft. Uitbreiding: zorg dat het programma telkens vraagt of je nog een nieuwe titel wilt opgeven. Indien nee, dan moet het programma stoppen, indien ja dan moet het programma doorgaan.

Bijlage 1: Tafelsommen stap voor stap (hoofdstuk 2)

1. Begin met: from livewires import *
2. Kies twee willekeurige getallen tussen 1 en 10 (met random_between(1,10)) en ken deze allebei toe aan een variabele (bijv. getal1 en getal2).

3. Toon met print een maalsom van die twee getallen.

4. Vraag naar het antwoord (met read_number()) en ken dit toe aan een variabele (bijv. antwoord).

5. Bereken de vermenigvuldiging van de twee willekeurige getallen en ken de waarde toe aan een variabele (bijv. resultaat).

6. Vergelijk in een if constructie de opgegeven waarde van punt 4 met de berekende waarde van punt 5 ( antwoord == resultaat ). Als deze gelijk zijn, toon dan met print dat het antwoord klopt. Als deze niet gelijk zijn ( else: ), toon dan met print dat het antwoord fout is en geef het goede antwoord.

7. Maak nu een herhalingslus met for x in 1,2,3,4,5,6,7,8,9,10: zodat er tien maalsommen achter elkaar opgegeven worden.

8. Zorg er tenslotte voor, dat de goede en foute antwoorden geteld worden en aan het eind met een print getoond worden. Voor het tellen heb je twee variabelen nodig, die eerst op 0 staan (bijv. goed = 0 en fout = 0). Vervolgens wordt goed steeds 1 meer (goed = goed + 1), als het antwoord goed is (dit moet dus in het if gedeelte) en fout steeds 1 meer als het antwoord fout is (dit moet dus in het else: gedeelte)

